Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 14, 2026 - 14:00 UTC
Scheduled
Observations from the RAWS network may be unavailable for 4 hours. Message from the provider: --- It will begin at 7am (MST) and last approximately four hours.
During this time frame, there will be a disruption in service and applications will be unavailable.
Posted Feb 10, 2026 - 18:02 UTC
This scheduled maintenance affected: Data providers (Government and other major datasets).