Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2025 - 14:00 UTC
Scheduled
For up to 4 hours we may be unable to fetch RAWS data from the upstream provider --- Monthly System Maintenance is scheduled on Saturday, March 15.
It will begin at 7am (MDT) and last approximately four hours. During this time frame, there will be a disruption in service and applications will be unavailable.
Posted Mar 11, 2025 - 18:40 UTC
This scheduled maintenance affected: Data providers (Major data providers).